Problema package grails 1.2.4+
01/10/2010 00:00
0
Olá pessoal, aqui na minha empresa usamos grails versão 1.0.3 e estamos para migrar para uma versão mais nova que suporte plugins. No entanto surgiu um problema sério quando pusemos a versão mais nova. O grails acaba criando um package com o nome da aplicação e na hora de rodar a aplicação dá erro pois a app não consegue achar o arquivo dentro da package. Se tirar da package funciona.

Aqui não queremos que venha sempre num pacote. Queremos ter a opção de não usar isso. Projetos pequenos não têm necessidade de usar este recurso. Na verdade nestes casos o recurso só causa transtorno.

Alguém sabe se tem como desabilitar isto nas novas versões? Se não tiver, será que nas versões que vierem eles vão tirar este recurso horroroso?
Tags: Grails


0
Boa tarde.

Tem como explicar um pouco melhor o que está acontecendo? Não consegui entender o problema e gostaria de te ajudar.
Abraço!
13/10/2010 00:00


0
Blz, vou explicar. As versões do grails a partir do 1.2.4 geram pacotes com o nome da aplicação. Mas na hora de executar a aplicação dá erro pois a aplicação não consegue enxergar que tem arquivo dentro do pacote.

Aqui na empresa temos uma aplicação pequena em grails usando versão 1.0. Não temos a necessidade de usar package pois a app possui poucos modelos. A dúvida é se tem como desativar este recurso de criação automática de package. E caso não, como fazer funcionar usando package? Pois não funciona assim aqui. Tenho que retirar os packages na mão para fazer funcionar.
18/10/2010 00:00



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto