Relatório por parâmetro fica todo branco
29/10/2011 01:25
0
Galera dar uma força ai, creio eu que seja coisa simples olha só estou gerando um relatório por parâmetros, no meu IReport já está tudo certo quando eu fiz o teste e ele pede o parâmetro que eu configurei para gerar o relatório. Agora no grails eu configurei assim e quando gero o relatório ele fica todo em branco.
Dar uma olhada no meu codigo por favor:


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="layout" content="main" />
<g:set var="entityName" value="${message(code: 'menu.label', default: 'Menu')}" />
<title><g:message code="default.list.label" args="[entityName]" /></title>
</head>
<body>
<div class="nav">
<g:jasperReport jasper="RelatorioMotorista" format="PDF" >
Qual o seu nome? <input type="Text" name="nome" /><br>
</g:jasperReport>
</div>
<body>
</html>


Valeu galera!!!!
Tags: IReport, dinâmico jasper


0
Galera já resolvi o problema era no nome do parâmetro que tem q ser igual ao do Ireport.

valeu
29/10/2011 02:08



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto