Não consigo baixar nenhum plugin
01/03/2013 20:38
0
Não consigo baixar nenhum plugin, por exemplo:

Tentei baixar o twitter bootstrap mas acontece o seguinte erro:

Loading Grails 2.1.1
| Configuring classpath.
| Environment set to development.....
| Resolving plugin bootstrap-theme. Please wait...
| Downloading: bootstrap-theme-1.0.RC3.pom.sha1
| Error resolving plugin [name:bootstrap-theme, group:org.grails.plugins, version:1.0.RC3]. Plugin not found.
| Error Plugin not found for name [bootstrap-theme] and version [1.0.RC3]

Alguém sabe qual é problema?

Tags: Erro em baixar e instalar plugin


0
Tem alguma coisa no BuildConfig?

na variavel repositories
01/03/2013 21:58


0
O que há o BuildConfig é:

repositories {
inherits true // Whether to inherit repository definitions from plugins

grailsPlugins()
grailsHome()
grailsCentral()

mavenLocal()
mavenCentral()

// uncomment these (or add new ones) to enable remote dependency resolution from public Maven repositories
//mavenRepo "http://snapshots.repository.codehaus.org"
//mavenRepo "http://repository.codehaus.org"
//mavenRepo "http://download.java.net/maven/2/"
//mavenRepo "http://repository.jboss.com/maven2/"
}


0
Vc está atrás de um proxy? Em caso afirmativo, vc precisa configurar o Grails para utilizá-lo.
02/03/2013 11:27


0
Não, apenas quero baixar e instalar os plugins do Grails, mas não consigo pois dá o erro apresentado acima. Sou iniciante no Grails e já pesquisei em vários locais e não encontro nada a respeito, inclusive algumas pessoas que estudam comigo encontram-se com o mesmo problema.


0
Aparentemente o problema não está na sua máquina, mas no servidor aonde o plugin deveria se localizar.

Faça o seguinte: desinstale o plugin excluindo a linha que corresponde ao seu nome presente no arquivo application.properties e em seguida tente instalá-lo novamente de acordo com as instalações do site do autor.

Em seguida, nos diga se funcionou ok?


0
Dentro da pasta do projeto execute:

grails install-plugin bootstrap-theme

Obs.: Mensagem complementar a do Kico.

Este é meu primeiro post na comunidade. Espero ajudar muitos e ser auxiliado por muitos mais.

Abraço!


0
Olá,

Passei um tempo sem trabalhar com grails e estou voltando agora.
Baixei o ggts mas ainda possuo umas versões antigas também com grails 1.3...

Seguinte, tanto no ggts como no sts antigo, quando estou criando um projeto novo não consigo baixar nenhum plugin. PS. não estou utilizando proxy.

Inclusive no buildConfig tirei os comentários dos repositórios mavenRepo.
Já tentei utilizar a versão 2.2.3.

E tá uma dificuldade para dá um refresh nas dependências ou baixar um plugin.
Alguém sabe se os servidores destes plugins estão com problema.

Depois de muitas tentativas para instalar o plugin por exemplo: barcode4j eu consegui e depois disso o comando para listar os plugins funcionou. Para isso eu baixei o plugin, coloquei no repositório, coloquei no application.properties todos os plugins já instalados de início da criação do projeto, que ele não tá fazendo isso e coloquei um warn em dependências para este plugin específico, depois disso funcionou, mas fiz esta mesma coisa no trabalho em linux, com proxy mesmo autenticado manualmente e não funcionou.

Detalhe: eu executei este grails list-plugins no cmd do windows para ver se listava e nada, inclusive ele independe de projeto.

Bem enfim o problema é que eu não consigo nem listar os plugins, quanto mais instalá-los.
28/06/2013 13:26


0
Caio Flávio,

Apesar da instalação de plugin ainda está funcionando de forma intermitente ainda, descobri o motivo desse problema.
Note que quando você instala um plugin aparece uma mensagem que o comando install plugin está obsoleto. Fui pesquisar sobre isso na internet e o que eu achei na documentação é que a forma para instalar o plugin seria através da tag dependency no buildConfig.groovy.
Sugiro utilizar esta forma ou aprender a trabalhar com maven. Estas mudanças ocorreram após a versão 2.x.x.
No momento ainda estou resistente a mudança, pois ainda vejo problemas ocorrendo ou ainda não aprendi a forma certa de instalar os plugins pelo buildConfig e fazendo um refresh nas dependências.
02/07/2013 08:47



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto