usando grails 2.3
12/11/2013 17:19
0
Olá pessoal,
Estou tentando passar a usar a versão 2.3 do grails, para isto eu fiz o download do grails 2.3.2 no site http://grails.org/download, criei um novo workspace e usando o GGTS criei um novo projeto grails selecionando a nova versão 2.3.2. ok.
Quando eu tento usar o comando "generate-controller" estou me deparando com a mensagem a seguir:
Configuring classpath
:: problems summary ::
:::: WARNINGS
::::::::::::::::::::::::::::::::::::::::::::::
:: UNRESOLVED DEPENDENCIES ::
::::::::::::::::::::::::::::::::::::::::::::::
:: org.springframework#spring-context;3.2.4.RELEASE: configuration not found in org.springframework#spring-context;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-tx;3.2.4.RELEASE: configuration not found in org.springframework#spring-tx;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-beans;3.2.4.RELEASE: configuration not found in org.springframework#spring-beans;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-core;3.2.4.RELEASE: configuration not found in org.springframework#spring-core;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-aspects;3.2.4.RELEASE: configuration not found in org.springframework#spring-aspects;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.slf4j#jcl-over-slf4j;1.7.5: configuration not found in org.slf4j#jcl-over-slf4j;1.7.5: 'master'. It was required from org.grails#grails-bootstrap;2.3.1 compile
:: org.slf4j#slf4j-api;1.7.5: configuration not found in org.slf4j#slf4j-api;1.7.5: 'master'. It was required from org.grails#grails-bootstrap;2.3.1 compile
:: org.springframework#spring-web;3.2.4.RELEASE: configuration not found in org.springframework#spring-web;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-spring;2.3.1 compile
:: org.springframework#spring-expression;3.2.4.RELEASE: configuration not found in org.springframework#spring-expression;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.springframework#spring-context-support;3.2.4.RELEASE: configuration not found in org.springframework#spring-context-support;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.springframework#spring-aop;3.2.4.RELEASE: configuration not found in org.springframework#spring-aop;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.aspectj#aspectjweaver;1.7.2: configuration not found in org.aspectj#aspectjweaver;1.7.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: asm#asm;3.3.1: configuration not found in asm#asm;3.3.1: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: org.aspectj#aspectjrt;1.7.2: configuration not found in org.aspectj#aspectjrt;1.7.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: cglib#cglib;2.2.2: configuration not found in cglib#cglib;2.2.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: org.springframework#spring-webmvc;3.2.4.RELEASE: configuration not found in org.springframework#spring-webmvc;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-web;2.3.1 compile
:: org.springframework#spring-jdbc;3.2.4.RELEASE: configuration not found in org.springframework#spring-jdbc;3.2.4.RELEASE: 'master'. It was required from org.springframework#spring-orm;3.2.4.RELEASE compile
::::::::::::::::::::::::::::::::::::::::::::::

:: problems summary ::
:::: WARNINGS
::::::::::::::::::::::::::::::::::::::::::::::
:: UNRESOLVED DEPENDENCIES ::
::::::::::::::::::::::::::::::::::::::::::::::
:: org.springframework#spring-context;3.2.4.RELEASE: configuration not found in org.springframework#spring-context;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-tx;3.2.4.RELEASE: configuration not found in org.springframework#spring-tx;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-beans;3.2.4.RELEASE: configuration not found in org.springframework#spring-beans;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-core;3.2.4.RELEASE: configuration not found in org.springframework#spring-core;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-datastore-core;2.0.2.RELEASE compile
:: org.springframework#spring-aspects;3.2.4.RELEASE: configuration not found in org.springframework#spring-aspects;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.slf4j#jcl-over-slf4j;1.7.5: configuration not found in org.slf4j#jcl-over-slf4j;1.7.5: 'master'. It was required from org.grails#grails-bootstrap;2.3.1 compile
:: org.slf4j#slf4j-api;1.7.5: configuration not found in org.slf4j#slf4j-api;1.7.5: 'master'. It was required from org.grails#grails-bootstrap;2.3.1 compile
:: org.springframework#spring-web;3.2.4.RELEASE: configuration not found in org.springframework#spring-web;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-spring;2.3.1 compile
:: org.springframework#spring-expression;3.2.4.RELEASE: configuration not found in org.springframework#spring-expression;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.springframework#spring-context-support;3.2.4.RELEASE: configuration not found in org.springframework#spring-context-support;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.springframework#spring-aop;3.2.4.RELEASE: configuration not found in org.springframework#spring-aop;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-core;2.3.1 compile
:: org.aspectj#aspectjweaver;1.7.2: configuration not found in org.aspectj#aspectjweaver;1.7.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: asm#asm;3.3.1: configuration not found in asm#asm;3.3.1: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: org.aspectj#aspectjrt;1.7.2: configuration not found in org.aspectj#aspectjrt;1.7.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: cglib#cglib;2.2.2: configuration not found in cglib#cglib;2.2.2: 'master'. It was required from org.grails#grails-core;2.3.1 runtime
:: org.springframework#spring-webmvc;3.2.4.RELEASE: configuration not found in org.springframework#spring-webmvc;3.2.4.RELEASE: 'master'. It was required from org.grails#grails-web;2.3.1 compile
:: org.springframework#spring-jdbc;3.2.4.RELEASE: configuration not found in org.springframework#spring-jdbc;3.2.4.RELEASE: 'master'. It was required from org.springframework#spring-orm;3.2.4.RELEASE compile
::::::::::::::::::::::::::::::::::::::::::::::

| Error Failed to resolve dependencies (Set log level to 'warn' in BuildConfig.groovy for more information):

- org.springframework:spring-context:3.2.4.RELEASE
- org.springframework:spring-tx:3.2.4.RELEASE
- org.springframework:spring-beans:3.2.4.RELEASE
- org.springframework:spring-core:3.2.4.RELEASE
- org.springframework:spring-aspects:3.2.4.RELEASE
- org.slf4j:jcl-over-slf4j:1.7.5
- org.slf4j:slf4j-api:1.7.5
- org.springframework:spring-web:3.2.4.RELEASE
- org.springframework:spring-expression:3.2.4.RELEASE
- org.springframework:spring-context-support:3.2.4.RELEASE
- org.springframework:spring-aop:3.2.4.RELEASE
- org.aspectj:aspectjweaver:1.7.2
- asm:asm:3.3.1
- org.aspectj:aspectjrt:1.7.2
- cglib:cglib:2.2.2
- org.springframework:spring-webmvc:3.2.4.RELEASE
- org.springframework:spring-jdbc:3.2.4.RELEASE


o comando "generate-controller" foi só um exemplo, quando tento usar outros comandos acontece a mesma coisa.
quando tento fazer via terminal percebo que ele carrega o grails 2.2.3 (versão que usava até então) e que fez download de muita coisa, até que caiu na mensagem acima.

eu alterei meu BuildConfig.groovy para utilizar o hibernate4 e comentei a parte do fork que está com problemas nessa versão, vou enviar o arquivo para facilitar alguma dúvida.

grails.servlet.version = "3.0" // Change depending on target container compliance (2.5 or 3.0)
grails.project.class.dir = "target/classes"
grails.project.test.class.dir = "target/test-classes"
grails.project.test.reports.dir = "target/test-reports"
grails.project.work.dir = "target/work"
grails.project.target.level = 1.6
grails.project.source.level = 1.6
//grails.project.war.file = "target/${appName}-${appVersion}.war"

//grails.project.fork = [
// configure settings for compilation JVM, note that if you alter the Groovy version forked compilation is required
// compile: [maxMemory: 256, minMemory: 64, debug: false, maxPerm: 256, daemon:true],

// configure settings for the test-app JVM, uses the daemon by default
// test: [maxMemory: 768, minMemory: 64, debug: false, maxPerm: 256, daemon:true],
// configure settings for the run-app JVM
// run: [maxMemory: 768, minMemory: 64, debug: false, maxPerm: 256, forkReserve:false],
// configure settings for the run-war JVM
// war: [maxMemory: 768, minMemory: 64, debug: false, maxPerm: 256, forkReserve:false],
// configure settings for the Console UI JVM
// console: [maxMemory: 768, minMemory: 64, debug: false, maxPerm: 256]
//]

grails.project.dependency.resolver = "maven" // or ivy
grails.project.dependency.resolution = {
// inherit Grails' default dependencies
inherits("global") {
// specify dependency exclusions here; for example, uncomment this to disable ehcache:
// excludes 'ehcache'
}
log "warn" // log level of Ivy resolver, either 'error', 'warn', 'info', 'debug' or 'verbose'
checksums true // Whether to verify checksums on resolve
legacyResolve false // whether to do a secondary resolve on plugin installation, not advised and here for backwards compatibility

repositories {
inherits true // Whether to inherit repository definitions from plugins

grailsPlugins()
grailsHome()
mavenLocal()
grailsCentral()
mavenCentral()
// uncomment these (or add new ones) to enable remote dependency resolution from public Maven repositories
//mavenRepo "http://repository.codehaus.org"
//mavenRepo "http://download.java.net/maven/2/"
//mavenRepo "http://repository.jboss.com/maven2/"
}

dependencies {
// specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes e.g.
// runtime 'mysql:mysql-connector-java:5.1.24'
}

plugins {
// plugins for the build system only
build ":tomcat:7.0.42"

// plugins for the compile step
compile ":scaffolding:2.0.1"
compile ':cache:1.1.1'

// plugins needed at runtime but not for compilation
runtime ":hibernate4:4.1.11.2" // or ":hibernate:3.6.10.3"
runtime ":database-migration:1.3.8"
runtime ":jquery:1.10.2"
runtime ":resources:1.2.1"
// Uncomment these (or add new ones) to enable additional resources capabilities
//runtime ":zipped-resources:1.0.1"
//runtime ":cached-resources:1.1"
//runtime ":yui-minify-resources:0.1.5"
}
}
Tags: grails 2.3


0
Cara as vezes com esses problemas de dependencias algumas pessoas sugerem apagar a pasta .grails :)
13/11/2013 11:23


0
acabei tentando começar do zero novamente e optei por usar o eclipse. criei novo workspace e novo projeto, acabou dando certo.
13/11/2013 12:04



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto