Erro no Eclipse com plugin grails
23/11/2015 10:31
0
Fala pessoal blz, ando estudando grails tem um tempo e sempre com este erro no eclipse com plugin no ggts, alguem ai teve o mesmo problema ?  o erro pode ser visto aqui ,

https://drive.google.com/file/d/0BzJsj3Uy5_fJRldfRE9MY3pLb0k/view
Tags: Grails


0
A versão do Grails na IDE está correta?


0
George,
O ggts foi descontinuado, sugiro que direcione seus estudos para o IntelliJ IDEA


0
kiko estou usando a versão 2.x do grails e plugin esta atualizado no eclipse
24/11/2015 13:10


0
Magno Machado Paulo foi descontinuado pensei que ainda esta em atividade, o IntelliJ IDEA no ainda nao adotei mesmo porq é pago
24/11/2015 13:11


0
Apesar de ter sido descontinuado, com o Grails 2.x ele funciona bem.

No caso Magno, este problema ocorre por causa da versão padrão do compilador Groovy configurado no seu workspace. Basta mudar para que seja a mesma usada pelo seu projeto na versão 2.x do Grails.


0
Na verdade ele tem uma versão gratuita (Community). Eu uso, atende perfeitamente.


0
Oi Magno,
esta versão community você está usando com qual versão do Grails?


1
Uso com Grails 3.x
Nunca usei com Grails 2.x, mas deve funcionar ainda melhor, já que neste caso o IDE entende diretamente que é um projeto Grails e portanto deve oferecer recursos específicos para Grails, enquanto projetos 3.x por enquanto são vistos apenas como projetos Gradle, mas dá para executar, testar, depurar, etc, tudo diretamente pela IDE através das tasks gradle, e quando quero executar algum comando específico do Grails como create-controller uso o console embutido na IDE


1
Oi Magno,

para a versão 2.x a versão community não oferece suporte.
Para o 3.x, faz sentido ela funcionar bem, pois ela deve entender seu projeto Grails como na realidade um projeto Gradle, para o qual a ferramenta oferece suporte total.


1
Eu achei este link https://tedvinke.wordpress.com/2015/10/17/eclipse-mars-grails-3-1-with-gradle-groovy-and-gsp-support/ onde é ensinado a configurar o eclipse mars para groovy e grails acho que ainda vai dar pra ficar com o eclipse mesmo eu achei que nao daria mas pra usar o eclipse
26/11/2015 21:41



Ainda não faz parte da comunidade???

Para se registrar, clique aqui.


Aprenda Groovy e Grails com a Formação itexto!

Newsletter Semana Groovy

Assinar

Envie seu link!


Livro de Grails


/dev/All

Os melhores blogs de TI (e em português) em um único lugar!

 
Creative Commons
RSS Grails Brasil é mantido por itexto Consultoria.
Em caso de problemas contacte Henrique Lobo Weissmann (Kico) por e-mail: kico@itexto.com.br
Todo o conteúdo presente neste site adota o Creative Commons como licença padrão.
Ver: 4.14.0
itexto